Re: DP6.11 - VEPA Running Slow (588 Views)
Reply
Valued Contributor
JDM_Nokia
Posts: 46
Registered: ‎04-13-2012
Message 1 of 10 (638 Views)

DP6.11 - VEPA Running Slow

[ Edited ]

 

I recently setup VEPA on my DP 6.11 running on an HP-UX 11.11 server.

 

The backups in question are on a VMware 4.1 system and are being backed up to a NULL device.  I also have a VMware legacy backup running on a VMware 4.0 system.  These backups are running to tape and they are faster than the VEPA backups.

 

Both the VMware 4.0 and 4.1 system are connected to the same EMC DMX SAN. 

 

When running a VEPA backup, it shows that it is using the SAN transport method.  Powerpath is installed on the backup host (Windows 2003 Server).  I have tried switching the policy from the default Basic Failover to Round Robin.  There was no speed improvement.

 

I believe that my issue is either with my VMware 4.1 setup or my network setup as I experience long delays when DP has to query information from vCenter. An example of this is when I create a new backup spec. After entering data for the first screen, it takes about a minute for the next screen to appear. 

 

I think that a good way to verify this would be to execute the applicable VM command that DP makes to the vCenter server outside of DP and see if it still runs slow.  Unfortunately, I do not know how this is done.

 

Thoughts?

 

 

Please use plain text.
Honored Contributor
JBasilio
Posts: 540
Registered: ‎11-25-2008
Message 2 of 10 (610 Views)

Re: DP6.11 - VEPA Running Slow

Hello

 

Please could you share with us a whole backup session report? Also please list of pacthes installed into cell manager and backup host.

Please use plain text.
Valued Contributor
JDM_Nokia
Posts: 46
Registered: ‎04-13-2012
Message 3 of 10 (606 Views)

Re: DP6.11 - VEPA Running Slow

 

 

The patches that are loaded are:

 

     Patch level         Patch description
     ===========================================
     PHSS_42698/PHSS_42699/DPSOL_00481/DPLNX_00187 Core Component
     PHSS_42700          Cell Manager Component
     PHSS_42704/PHSS_42705/DPSOL_00484/DPLNX_00190 Disk Agent
     PHSS_42706/PHSS_42707/DPSOL_00485/DPLNX_00191 Media Agent
     PHSS_42702/PHSS_42703/DPSOL_00483/DPLNX_00189 User Interface
     PHSS_40817/PHSS_40818/DPSOL_00411/DPLNX_00117 Java User Interface
     PHSS_41725/PHSS_41726/DPSOL_00434/DPLNX_00140 English Documentation & Help
     Number of patches found: 7.

A session report has been attached...

 

Please use plain text.
Honored Contributor
Sebastian.Koehler
Posts: 1,157
Registered: ‎02-27-2007
Message 4 of 10 (588 Views)

Re: DP6.11 - VEPA Running Slow

[ Edited ]

Try to setup and use a null device on the Windows backup host daebu40 and provide a new session report. Just enter nul for the Windows device file.

Regards,
Sebastian

---
Assign a kudo to this post, if you find it useful.
Please use plain text.
Valued Contributor
JDM_Nokia
Posts: 46
Registered: ‎04-13-2012
Message 5 of 10 (573 Views)

Re: DP6.11 - VEPA Running Slow

 

Sebastian,

 

Looks like you are on to something as the backup time was cut in half (25 minutes versus 1 hour).  I have attached the backup report.  I also realised that I forgot to post the patches loaded onto the backup host.  Those are below.

 

I am going to need to look at the network between the backup host (DAEBU40) and the CM (DAEBU01).  Something there is slowing things down.

 

Let me know if you have any other thoughts.

 

Appreciate the help!

 

Jeff

 

DAEBU40 patches:

 

Patch level         Patch description
===========================================
DPWIN_00557         Core Component
DPWIN_00557         Core of Integrations component
DPWIN_00560         Disk Agent
DPWIN_00561         Media Agent
DPWIN_00559         User Interface
DPWIN_00480         MS SQL Integration
DPWIN_00486         Oracle Integration
DPWIN_00508         MS Volume Shadow Copy Integration
DPWIN_00467         VMware Integration (legacy)
DPWIN_00518         English Documentation & Help
DPWIN_00511         Virtual Environment Integration
Number of patches found: 11.

Please use plain text.
Honored Contributor
Sebastian.Koehler
Posts: 1,157
Registered: ‎02-27-2007
Message 6 of 10 (569 Views)

Re: DP6.11 - VEPA Running Slow

Ok, that looks better now. Could you check PowerPath configuration on backup host daebu40? I don't think you're able to increase read operation performance during backup using a different load balancing policy for the DMX LUNs. I think the limiting factor is the Windows 2003 host now. Try to backup two VMs at once. You should see 2x 40MBs. Consider using Windows 2008 R2 or Windows 2003 x64 as a backup host.

 

Regards,

Sebastian

---
Assign a kudo to this post, if you find it useful.
Please use plain text.
Valued Contributor
JDM_Nokia
Posts: 46
Registered: ‎04-13-2012
Message 7 of 10 (546 Views)

Re: DP6.11 - VEPA Running Slow

[ Edited ]

 

Hey Sebastian,

 

Ran the same backup with two VMs.  Both VMs used SAN transport method.  Speed was down a bit.  One ran at 36.6 MB/s and the second ran at 29.84. 

 

I am working on getting at Windows 2008 physical box setup as a backup host.  Looks like this may take some time as I need to procure some HW.

 

Thanks!

 

Jeff

Please use plain text.
Honored Contributor
Sebastian.Koehler
Posts: 1,157
Registered: ‎02-27-2007
Message 8 of 10 (540 Views)

Re: DP6.11 - VEPA Running Slow

You could also try to setup an virtual Windows 2008 R2 host and use Hot-add method for VADP. If your ESXi network configuration is working fine, you should be able to see good performance using a "virtual proxy". In my environment I've seen up to 130MB/s for a single VM using hotadd written down to a null device. This was a Linux x86_64 backup proxy running Data Protector 7.01.

 

Regards,

Sebastian

---
Assign a kudo to this post, if you find it useful.
Please use plain text.
Valued Contributor
JDM_Nokia
Posts: 46
Registered: ‎04-13-2012
Message 9 of 10 (465 Views)

Re: DP6.11 - VEPA Running Slow

 

Well I finally got my W2008R2 server setup.  The backup times are faster, but not that much faster (see attachments) when writing to tape. 

 

I opened up a case with DP and they seem to think that the issue is that auto negotiation is setup on my backup network.  I am not seeing slow backups, but at the same time all of my Windows backups are coming from a VMware server versus a physical server.  I am going to chat with my network folks to see if I can make this change.

 

I was not aware that a backup host could be virtual.  Does this appy to DP 6.11?  If I can do this with this version of DP, I will try to set this up on one of my VMware farms.

 

Let me know if you have any other thoughts.

 

Thanks!

 

 

Please use plain text.
Valued Contributor
JDM_Nokia
Posts: 46
Registered: ‎04-13-2012
Message 10 of 10 (463 Views)

Re: DP6.11 - VEPA Running Slow

 

I have identified a W2008R2 VM that I am going to use as a backup host. 

 

As per normal, I have to get the firewall people to open port 443.

 

Should have something setup in the early part of next week.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation