Re: Couldn't see the tape barcode in IBM 3584 library (489 Views)
Reply
Frequent Advisor
Chris shi
Posts: 84
Registered: ‎10-19-2007
Message 1 of 4 (541 Views)

Couldn't see the tape barcode in IBM 3584 library

Dears

 

We are using DP7.0 with IBM 3584 library. Everything is well except the tape barcode. Because we can't find the tape barcode in DP GUI. And the barcode scan can't be performed.

 

The library works well because it can be recognized by NBU... The CM platform is linux.

 

Could you give me some suggestion? Thanks very much.

Valued Contributor
nikhil_d
Posts: 122
Registered: ‎09-21-2012
Message 2 of 4 (505 Views)

Re: Couldn't see the tape barcode in IBM 3584 library

I had this problem recently with a MSL, and HP support told us that DP just returns the data read by the library CommandView.

 

Does the CommandView (in your case Library Manager) read the data correctly?

 

For us the solution was to use a different barcode label (different paper than we normally use).

HP Expert
Stewart_Macleod
Posts: 45
Registered: ‎09-02-2013
Message 3 of 4 (489 Views)

Re: Couldn't see the tape barcode in IBM 3584 library

Something else to look at.

 

Just in case it is not set, check as follows...

In the Devices and Media context
Devices
Right click on the library's name and select Properties
In the right pane in the "Control" tab there is
"Barcode reader support"
Is that checked ?   If not check it and click on Apply.

HP Expert
Stewart_Macleod
Posts: 45
Registered: ‎09-02-2013
Message 4 of 4 (471 Views)

Re: Couldn't see the tape barcode in IBM 3584 library


A test you could do
   Devices and Media context, Right click on "Devices", "Autoconfigure Devices"
   Choose the hostname of the system you want to control the robotic.
   Next.   wait a little time
   Hopefully the drives and robotic become visable and selectable.
   Select them and Finish (don't worry about the other settings, unless you think you will use the new config)
   Expand Devices and you should see your new library config.
   Right click and choose barcode scan.

Suppose that works OK, you get the barcodes you need, you then have 2 options

1. Compare this new library config with the older problem "barcodes fail" library config.
   Hopefully you will see a difference, then change the problem library config, so it works.
   Then you can delete the new library config.

or

2. Change your backup specifications to use the new library config (this could be quite lot of work if you have a lot of specs).

Suppose it does not work (new lib config does not see the barcodes) possibly
there is a problem outside of DP.

Are you sure the tapes in library have barcodes on them ?

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.