Re: 90:51 Cannot write to device (Details unknown.) (728 Views)
Reply
Occasional Advisor
victor-c
Posts: 11
Registered: ‎10-11-2012
Message 1 of 6 (786 Views)

90:51 Cannot write to device (Details unknown.)

Hi,

 

I have configuration:

1. 

HP_DP_8.00_for_Linux_TD586-15008 installed on RHEL 6.3

 

[root@server1 ~]# service xinetd status

xinetd (pid 16998) is running...

 

[root@server1  ~]# /opt/omni/sbin/omnisv status
ProcName Status [PID]
===============================
crs : Active [15275]
mmd : Active [15273]
kms : Active [15274]
hpdp-idb : Active [13965]
hpdp-idb-cp : Active [13996]
hpdp-as : Active [15340]
omnitrig : Active
Sending of traps disabled.
===============================
Status: All Data Protector processes/services up and running.

 

2. MSL2024 G3 Series with Ultrium 5-SCSI, FC interface 

[root@server1 ~]# dmesg |grep scsi
...

scsi 0:0:3:0: Sequential-Access HP Ultrium 5-SCSI Y5BW PQ: 0 ANSI: 6
scsi 0:0:3:1: Medium Changer HP MSL G3 Series 5.70 PQ: 0 ANSI: 5
...

scsi 0:0:3:0: Attached scsi generic sg3 type 1
scsi 0:0:3:1: Attached scsi generic sg4 type 8
...

 

[root@server1 ~]# cat /proc/scsi/scsi

Attached devices:
...

Host: scsi0 Channel: 00 Id: 03 Lun: 00
Vendor: HP Model: Ultrium 5-SCSI Rev: Y5BW
Type: Sequential-Access ANSI SCSI revision: 06
Host: scsi0 Channel: 00 Id: 03 Lun: 01
Vendor: HP Model: MSL G3 Series Rev: 5.70
Type: Medium Changer ANSI SCSI revision: 05
...

 

3.

CellManager installed on WinSrv2008R2_SP1.

img01.PNG

 

Problem: 

After "Autoconfigure Devices..." media (catriges) are not inserted in "Default LTO-Ultrium" media pool. And then I tried to format media I have error message:

 

[Normal] From: MSM@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 17:58:57
Media session 2013/08/06-37 started.

[Normal] From: MMA@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 17:58:57
STARTING Media Agent "HP:Ultrium 5-SCSI_1_server1"

[Normal] From: MMA@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 17:58:57
=> UMA@server1@/dev/sg4
Loading medium from slot 5 to device /dev/nst0

[Normal] From: MSM@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 17:59:57
Blank medium found.
Initialization allowed.

[Normal] From: MMA@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 17:59:57
/dev/nst0
Initializing new medium: "[DYW467L5] DYW467L5"

[Major] From: MMA@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 17:59:57
[90:51] /dev/nst0
Cannot write to device (Details unknown.)

[Major] From: MMA@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 17:59:57
Initialization of medium failed.

[Normal] From: MMA@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 18:00:34
Ejecting medium '5'.

[Normal] From: MMA@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 18:00:34
=> UMA@server1@/dev/sg4
Unloading medium to slot 5 from device /dev/nst0

[Normal] From: MMA@server1 "HP:Ultrium 5-SCSI_1_server1" Time: 06.08.2013 18:01:08
ABORTED Media Agent "HP:Ultrium 5-SCSI_1_server1"


============================================================================
0 media out of 1 successfully initialized.
============================================================================

 

 

Can you help me?

[90:51] /dev/nst0 Cannot write to device (Details unknown.)

 

Please use plain text.
Honored Contributor
Shishir Misra
Posts: 432
Registered: ‎12-19-2004
Message 2 of 6 (772 Views)

Re: 90:51 Cannot write to device (Details unknown.)

Hi.

     Check your server's messages file for entries around the time stamp of the DP error. These entries could help you understand what's happening.

Regards,

Shishir

Please use plain text.
Occasional Advisor
victor-c
Posts: 11
Registered: ‎10-11-2012
Message 3 of 6 (768 Views)

Re: 90:51 Cannot write to device (Details unknown.)

[ Edited ]

Hi, Shishir

 

In attachment are some log from /var/opt/omni/server/log directory.

 

From this log file I can't found any solutions. May you can help me.

 

Best regards,

Victor

 

P.S.: do you need another logs?

Please use plain text.
Occasional Advisor
victor-c
Posts: 11
Registered: ‎10-11-2012
Message 4 of 6 (756 Views)

Re: 90:51 Cannot write to device (Details unknown.)

Additional, than I try to make backup (for examle VmWare VM):

 

[Normal] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:03:38
Backup session 2013/08/07-1 started.

[Normal] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:03:39
OB2BAR application on "vmd-srv-vcenter" successfully started.

[Normal] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:03:07
VerifySSLCertificates register key created.

2013-08-07T16:03:07.505+03:00 [07772 info 'Default'] Initialized channel manager
2013-08-07T16:03:07.505+03:00 [07772 info 'Default'] Current working directory: C:\Windows\system32
2013-08-07T16:03:07.505+03:00 [07772 verbose 'ThreadPool'] TaskMax=10, IoMin=1, IoMax=21
[Normal] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:03:08
Resolving objects for backup on vCenter 'vmd-srv-vcenter' ...

[Normal] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:03:09
Add Virtual Machine 'VM-xx-WIN7' to the backup ...

[Normal] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:03:10
Virtual Machine 'VM-xx-WIN7': Locking vMotion ...

[Normal] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:03:11
Creating folder C:\ProgramData\OmniBack\tmp\9ed4bd01-7ad3-4ac1-a588-81de919219ba ...

[Normal] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:03:19
Virtual Machine 'VM-xx-WIN7': Backing up configuration file VM-xx-WIN7.vmx ...

[Normal] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:03:19
Virtual Machine 'VM-xx-WIN7': Creating snapshot ...

2013-08-07T16:04:07.510+03:00 [09876 trivia 'ThreadPool'] PrepareToWait: Starting new thread
2013-08-07T16:04:07.512+03:00 [07272 trivia 'ThreadPool'] PrepareToWait: Starting new thread
2013-08-07T16:04:07.532+03:00 [07272 trivia 'ThreadPool'] PrepareToWait: Starting new thread
2013-08-07T16:04:07.544+03:00 [08024 trivia 'ThreadPool'] PrepareToWait: Starting new thread
[Normal] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:04:54
Virtual Machine 'VM-xx-WIN7' (UUID '420539f3-3c5d-59c0-7468-928d4ce77abc'): Starting full backup ...

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:05:27
STARTING Media Agent "HP:Ultrium 5-SCSI_1_vmd-srv-app2"

[Warning] From: BSM@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:05:27
___________________________________________________________________
Mount request for any medium (blank or without protection):
Device : HP:Ultrium 5-SCSI_1_vmd-srv-app2
Host : vmd-srv-app21
Slot : 10
___________________________________________________________________


[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:05:46
=> UMA@vmd-srv-app21@/dev/sg4
Loading medium from slot 10 to device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:06:47
Medium "8d02000a:5200e303:7cd9:0001" in device "HP:Ultrium 5-SCSI_1_vmd-srv-app2"
is Data Protector foreign medium.
The medium will not be used for backup.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:07:00
/dev/nst0
Medium header verification completed, 0 errors found.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:07:20
Ejecting medium '10'.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:07:20
=> UMA@vmd-srv-app21@/dev/sg4
Unloading medium to slot 10 from device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:07:51
___________________________________________________________________
Mount request for any medium (blank or without protection):
Device : HP:Ultrium 5-SCSI_1_vmd-srv-app2
Host : vmd-srv-app21
Slot : 2
___________________________________________________________________


[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:07:57
=> UMA@vmd-srv-app21@/dev/sg4
Loading medium from slot 2 to device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:08:58
Medium "8d02000a:5200ed6a:15f1:0001" in device "HP:Ultrium 5-SCSI_1_vmd-srv-app2"
is Data Protector foreign medium.
The medium will not be used for backup.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:09:11
/dev/nst0
Medium header verification completed, 0 errors found.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:09:30
Ejecting medium '2'.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:09:30
=> UMA@vmd-srv-app21@/dev/sg4
Unloading medium to slot 2 from device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:10:01
___________________________________________________________________
Mount request for any medium (blank or without protection):
Device : HP:Ultrium 5-SCSI_1_vmd-srv-app2
Host : vmd-srv-app21
Slot : 21
___________________________________________________________________


[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:10:57
=> UMA@vmd-srv-app21@/dev/sg4
Loading medium from slot 21 to device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:11:59
[61:7109] Medium in device "HP:Ultrium 5-SCSI_1_vmd-srv-app2" cannot be initialized.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:12:18
Ejecting medium '21'.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:12:18
=> UMA@vmd-srv-app21@/dev/sg4
Unloading medium to slot 21 from device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:12:51
___________________________________________________________________
Mount request for any medium (blank or without protection):
Device : HP:Ultrium 5-SCSI_1_vmd-srv-app2
Host : vmd-srv-app21
Slot : 21
___________________________________________________________________


[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:13:00
=> UMA@vmd-srv-app21@/dev/sg4
Loading medium from slot 21 to device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:13:56
[61:7109] Medium in device "HP:Ultrium 5-SCSI_1_vmd-srv-app2" cannot be initialized.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:14:14
Ejecting medium '21'.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:14:14
=> UMA@vmd-srv-app21@/dev/sg4
Unloading medium to slot 21 from device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:14:47
___________________________________________________________________
Mount request for any medium (blank or without protection):
Device : HP:Ultrium 5-SCSI_1_vmd-srv-app2
Host : vmd-srv-app21
Slot : 21
___________________________________________________________________


[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:14:54
=> UMA@vmd-srv-app21@/dev/sg4
Loading medium from slot 21 to device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:15:50
[61:7109] Medium in device "HP:Ultrium 5-SCSI_1_vmd-srv-app2" cannot be initialized.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:16:09
Ejecting medium '21'.

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:16:09
=> UMA@vmd-srv-app21@/dev/sg4
Unloading medium to slot 21 from device /dev/nst0

[Warning] From: BSM@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:16:42
___________________________________________________________________
Mount request for any medium (blank or without protection):
Device : HP:Ultrium 5-SCSI_1_vmd-srv-app2
Host : vmd-srv-app21
Slot : 21
___________________________________________________________________


[Normal] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:16:55
Session abort request received by user ADMINISTRATOR.VMD-SRV-BACKUP1@vmd-srv-backup1.

[Major] From: OB2BAR_VEPA_BAR@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:16:23
Received ABORT request from BSM (ERR: Error starting backup/restore (BMA cannot be started or similar).)

[Normal] From: BMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 16:16:55
ABORTED Media Agent "HP:Ultrium 5-SCSI_1_vmd-srv-app2"

[Critical] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:16:23
Exception Caught
[Critical] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:16:23
Backup of object failed.

[Normal] From: VEPALIB_VMWARE@vmd-srv-vcenter "/VMD" Time: 07.08.2013 16:16:23
Virtual Machine 'VM-xx-WIN7': Unlocking vMotion ...

Deleted directory C:\TEMP\vmware-SYSTEM\420539f3-3c5d-59c0-7468-928d4ce77abc-vm-148\hotadd
[Normal] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:17:45
OB2BAR application on "vmd-srv-vcenter" disconnected.

[Normal] From: BSM@vmd-srv-app21 "Test_VM-WinXX" Time: 07.08.2013 16:17:45

Backup Statistics:

Session Queuing Time (hours) 0,00
-------------------------------------------
Completed Disk Agents ........ 0
Failed Disk Agents ........... 0
Aborted Disk Agents .......... 1
-------------------------------------------
Disk Agents Total ........... 1
===========================================
Completed Media Agents ....... 0
Failed Media Agents .......... 0
Aborted Media Agents ......... 1
-------------------------------------------
Media Agents Total .......... 1
===========================================
Mbytes Total ................. 0 MB
Used Media Total ............. 0
Disk Agent Errors Total ...... 0


============================================================================
Session aborted!
============================================================================

 

 

Servers log are in attachment.

Please use plain text.
Occasional Advisor
victor-c
Posts: 11
Registered: ‎10-11-2012
Message 5 of 6 (754 Views)

Re: 90:51 Cannot write to device (Details unknown.)

Additional 2.

 

Then I try to import media:

 

[Normal] From: MSM@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 17:04:07
Media session 2013/08/07-2 started.

[Normal] From: MMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 17:04:07
STARTING Media Agent "HP:Ultrium 5-SCSI_1_vmd-srv-app2"

[Normal] From: MMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 17:04:07
=> UMA@vmd-srv-app21@/dev/sg4
Loading medium from slot 1 to device /dev/nst0

[Normal] From: MSM@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 17:05:14
Data Protector foreign medium "8d02000a:520107fd:25c4:0001" found.

[Critical] From: MMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 17:05:14
[90:6106] Unexpected encryption related error was encountered.

[Major] From: MMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 17:05:14
[90:53] /dev/nst0
Cannot seek to requested position (Details unknown.)

[Normal] From: MMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 17:05:41
Ejecting medium '1'.

[Normal] From: MMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 17:05:41
=> UMA@vmd-srv-app21@/dev/sg4
Unloading medium to slot 1 from device /dev/nst0

[Normal] From: MMA@vmd-srv-app21 "HP:Ultrium 5-SCSI_1_vmd-srv-app2" Time: 07.08.2013 17:06:14
ABORTED Media Agent "HP:Ultrium 5-SCSI_1_vmd-srv-app2"


============================================================================
0 media out of 1 successfully imported.
============================================================================

Please use plain text.
Honored Contributor
Shishir Misra
Posts: 432
Registered: ‎12-19-2004
Message 6 of 6 (728 Views)

Re: 90:51 Cannot write to device (Details unknown.)

Hi.

    I was actually asking for your Linux server's messages file - /var/log/messages. I think you're getting mount requests because your initial format job is failing. I don't know why you are running into encryption related errors - have you enabled encryption on your tape drives?

Regards,

Shishir

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation