A5800 vlan and trunk questions (1067 Views)
Reply
Frequent Advisor
Erick Arturo Perez
Posts: 74
Registered: ‎02-28-2008
Message 1 of 3 (1,067 Views)

A5800 vlan and trunk questions

Hi, im new to this A5800 switch. Currently there is a core switch (extreme networks) where all vlans are defined. For a special project we want to create a trunk (4 port) betwen the Extreme switch and the HP A5800. The A5800 will have a bunch of servers attached to the other ports.

 

So far my config:

#
 version 5.20, Release 1211P01
#
 sysname HP5800
#
 clock timezone #Web#-5#01 minus 05:00:00 
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
#
 domain default enable system 
#
 telnet server enable 
#
vlan 1
#
vlan 2
 description iSCSI VLAN
#
radius scheme system
 primary authentication 127.0.0.1 1645
 primary accounting 127.0.0.1 1646
 user-name-format without-domain
#
domain system 
 access-limit disable 
 state active 
 idle-cut disable 
 self-service-url disable 
#
user-group system
#
local-user support
 password cipher xxxxxx!!
 authorization-attribute level 3
 service-type lan-access
 service-type telnet
 service-type ftp
 service-type portal
#
interface Bridge-Aggregation1
 description "4 port trunk to core switch"
 port link-type trunk
 port trunk permit vlan 1 164
#
interface NULL0
#
interface Vlan-interface1
 description "our A5800 is routing between these networks"
 ip address 10.252.164.94 255.255.255.128 
 ip address 172.128.172.99 255.255.255.0 sub
#
interface GigabitEthernet1/0/1
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 164
 port link-aggregation group 1
#
interface GigabitEthernet1/0/2
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 164
 port link-aggregation group 1
#
interface GigabitEthernet1/0/3
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 164
 port link-aggregation group 1
#
interface GigabitEthernet1/0/4
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 164
 port link-aggregation group 1
#
interface GigabitEthernet1/0/5
 port link-mode bridge
 port link-aggregation group 1
#
 ip route-static 0.0.0.0 0.0.0.0 Vlan-interface1 10.252.164.1
#
 ntp-service source-interface Vlan-interface1
 ntp-service unicast-server 10.252.164.95
#
 load xml-configuration 
#
 load tr069-configuration
#
user-interface aux 0
user-interface vty 0
 set authentication password simple justtesting
user-interface vty 1 15
#

 

From the Extreme switch (core) side, a 4 port trunk LACP mode has been created. This core switch has all the vlans defined. In the case of my A5800 I just want all vlans to pass to A5800, If I simply connect a port form the A5800 to the core switch then all works fine, but at trunk creation traffic does not pass. I know I am missing some more configuration, but reading the HP docs and following examples got me this far.

What am I missing here in the trunk creation?

Note: there is also a VLAN 1 defined at the core switch as I noted that this A5800 has also a VLAN defined. Also, being new on VLAN configs I think what I am missing is how to define to the trunk that all vlans should traverse the link, right?

 

thanks for your guidance and/or reference to other web examples.

 

 

Trusted Contributor
Richard Litchfield
Posts: 266
Registered: ‎07-11-2003
Message 2 of 3 (1,018 Views)

Re: A5800 vlan and trunk questions

In the Bridge aggregation group, you may need to set the mode to dynamic (that is required when connecting Comware to ProCurve switches). In the example below, I have also enabled all VLANs, rather than allowing just specified ones.

interface Bridge-Aggregation1
 description Link to 2920-stack
 port link-type trunk
 port trunk permit vlan all
 port trunk pvid vlan 930
 link-aggregation mode dynamic

 

The order is important too.

  1. create bagg
  2. set bagg to dynamic
  3. set each interface to be a member of the bagg
  4. in the bagg, set the trunk and VLAN configs

 

 

Occasional Collector
ktako
Posts: 3
Registered: ‎09-15-2013
Message 3 of 3 (1,007 Views)

Re: A5800 vlan and trunk questions

The order of crerating your BAGG is important and should be done as indiacated by Richard.

 

An assumtion is also that you have already defined VLANS

 

When you attach your vlans to the BAGG in the final step you should see something like  following output message on your  console

 


 Please wait........................................... Done.
 Configuring GigabitEthernet1/0/49........................................... Done.
 Configuring GigabitEthernet5/0/49........................................... Done.

 

 

Here is an example configuration for HP Comware and Cisco  using Bridge Aggregation (HP)  and Port Channel (Cisco)

 

********************************************HP Comware*******************************************************

vlan 1 to 900

interface Bridge-Aggregation1

description link to Cisco
link-aggregation mode dynamic
quit

 

int gig 1/0/49
shut

description link to Cisco gig 1/3
port link-aggregation group 1

 

int gig 5/0/49
shut

description link to Cisco gig 1/5
port link-aggregation group 1


interface Bridge-Aggregation 1

description link to Cisco

port link-type trunk
port trunk permit vlan all

 

************The below  will be seen when the vlans are permitted*****************************


 Please wait........................................... Done.
 Configuring GigabitEthernet1/0/49........................................... Done.
 Configuring GigabitEthernet5/0/49........................................... Done.
 

int gig 1/0/49
undo shut

int gig 5/0/49
undo shut


**or on the  HP  switch change the following if you use a different PVID in this example 990, and to allow specific vlans**

 

interface Bridge-Aggregation 1

description link to Cisco
port link-type trunk
undo port trunk permit vlan all

port trunk pvid vlan 990
port trunk permit vlan 1 to 899

 

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.