Re: UCMDB Discovery Error (158 Views)
Reply
Contributor
Sree50
Posts: 13
Registered: ‎06-27-2011
Message 1 of 3 (183 Views)

UCMDB Discovery Error

[ Edited ]

When am running a discovery job under Host resources and application, am getting the error as given below. What could be the reason for it?  As per the error looked into the file, not sure what change has to be made.

 

<< Progress message, Severity: Error>>
Failed to discover processes by wmi

<< Progress message, Severity: Error>>
Traceback (innermost last):
File "<string>", line 2, in ?
File "wmi_dis_all", line 145, in DiscoveryMain
TypeError: __init__() too many arguments; expected 2 got 5

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. -HP Forum Moderator

Trusted Contributor
PuneetS
Posts: 103
Registered: ‎11-03-2011
Message 2 of 3 (161 Views)

Re: UCMDB Discovery Error

Hi Sree,

 

Could you please give more info like:

 

1. Have you configured the wmi credentials?

2. Have you run the Host Connection by WMI to discover WMI CITs?

3. Are you getting this error for single machine or multiple?

4. Also if you could provide any log file and communication log it would be helpful.

 

Regards,

Puneet 

Regards
Puneet

If you find this reply helpful, Click the KUDOS button on the left to say 'Thanks'
Valued Contributor
NagendraPaladi
Posts: 188
Registered: ‎06-16-2009
Message 3 of 3 (158 Views)

Re: UCMDB Discovery Error

Hi,

 

Looking in to the error, I observe that you are trying to give 5 paramerters to the discovery job wehre as your job needs only two attributes. Make the changes in the Adapter Configuration.

 

Regards,

Nagendra Swamy. P

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.