Re: BPT issue: QTP unable to open an ALM component (1099 Views)
Reply
Senior Member
ElesarRepolido
Posts: 3
Registered: ‎03-21-2011
Message 1 of 3 (1,204 Views)

BPT issue: QTP unable to open an ALM component

I have an on-going issue with BPT solution, and there is already a logged HPSS ticket on this. 

 

However 3 months already passed, and there is still no definite solution to my problem. 

Screenshots were taken by the assigned engineer, but no clear direction yet.
I ma afraid we are not close to the resolution yet.

 

The problem, which i wanted to solicit help on is documented in the attached file on this post.

 

The problem that my current team have, when i try to open an automated component through QTP there are at  2 dialog boxes that appears. At the end, nothing is opened. 

 

The dialog boxes has these messages:
- Cannot find the data table file ....
-  Unexpected file format

Thanks in advance for the help and pointers.  

Respected Contributor
Martin Sander
Posts: 486
Registered: ‎10-20-2008
Message 2 of 3 (1,189 Views)

Re: BPT issue: QTP unable to open an ALM component

Hi Elesar

 

For the first message - open a blank Excel worksheet and save it to the location mentioned. This file is the default datatables used by QTP.

 

For the second message, not good news I'm afraid. This relates to a corrupt file on the database. I have experienced the same issue in the past. It usually happens when a save failed. I have not found a solution and the only option has been to delete in QC as recreate from a copy or from scratch.

 

Hope this helps

 

Thanks

Martin

Respected Contributor
Erodabasi Atacan
Posts: 588
Registered: ‎01-16-2008
Message 3 of 3 (1,099 Views)

Re: BPT issue: QTP unable to open an ALM component

Hi Elesar,

1. you need write permission to the "...Temp\TD_80" folder.. <-- this is very important

2. Uninstall the QC Client (via CleanUninstaller) and install it "As Admin" (If Win7 then deactivate UAC (User Account Control) before installing)

3. I hope you installed also QTP and the QTP Addin for QC (or ALM) by deactivating UAC and installing as "As Admin" and open QTP and connected once with the QC

 

4. When you try to open a component that is created in an older version then you have to update the component. Was there a upgrade from QTP/QC in the last time? ;)

 

Kind regards,

A.E.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.