Intermittent Black Screen- HP Touchmsmart 9300 Elite (90 Views)
Reply
Occasional Visitor
Superbird
Posts: 1
Registered: ‎06-24-2014
Message 1 of 1 (90 Views)

Intermittent Black Screen- HP Touchmsmart 9300 Elite

Reposting this here as it has been pointed out that this is a commercial product.

 

I am an EE Tech with over 35 years of expperience, 23 of them at HP!  I have an HP TouchSmart 9300 Elite AIO Product# XZ994UT#ABA.  Warranty ended 10-17-2013.  I am having problems with intermittent black screens that are temperature related.  At normal room temperatures the PC will sometimes boot, but with no screen.  If I cool the PC it will often come up with the screen working and it will remain working until shut down.  I swapped the inverter with a known good one from another 9300 but it was still temperature sensitive.

 

To make a long story short, I have narrowed the problem down to the MOBO, cooling around U1 (to the left of the CPU looking at the MOBO from the back of the PC) will allow it to start up with the inverter working.  At the inverter, the pin 5th from the right (looking at the connector from the back of the PC) is high and the 6th from the right is pulsing when the inverter is working, both are low when it is not.  There are other issues that look like a power-on reset problem or similar when it fails to boot or start the inverter.  U1 does not seem to be the problem as the inverter does not start if only U1 is cooled, I suspect the issue is a part on the opposite side of the board.  I don't think I can get the board loose and continue the boot testing, there are too many things that need to be disconnected to get the board out.  Is there one or more ICs opposite U1 that could cause this and if so what are the part numbers and are they available anywhere?  I know most people don't go to this length to fix a PC, but I would like to keep this system going as it is configured if at all possible, and I just started a new job after several months searching so cash is short!  I can do the board repair if I can pinpoint the problem or find the suspect chip(s) to swap out, unless it is a BGA.

 

Does anyone have photos of the MOBO showing the components on the "back side" below U1?  I know this is a long shot and I should be looking for a replacement MOBO or a unit with a broken screen, etc.  Any help will be appreciated.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.