Re: uCMDB and uCMDB probe do not synchronise credentials during SAP ABAP discovery job (761 Views)
Reply
Advisor
WDBSort1
Posts: 12
Registered: ‎08-07-2012
Message 1 of 7 (861 Views)

uCMDB and uCMDB probe do not synchronise credentials during SAP ABAP discovery job

Hi.

 

We have set up uCMDB 10.0 loaded with content pack 11 along with the uCMDB probe 10.0, on the same server.

 

The problem we experience is that while trying to run the SAP ABAP Connection by JCO we get the following error returned : "sapprotocol: No credentials defined for the triggered ip".

 

We have manually tested the Credentials entered in the SAP Protocol page via the test credential tool, and the connections were successful.

 

What could be the problem? Is it that the uCMDB server & uCMDB probe do not sync all the credentials entered?

 

Any help would be appreciated.

 

Attached is the SAP ABAP Connection by JCO discovery job log in the communication log.

 

Thank you.

 

Regards,

 

Wynand.

 

Honored Contributor
Mohamed AbdelMoneim
Posts: 2,142
Registered: ‎11-26-2008
Message 2 of 7 (835 Views)

Re: uCMDB and uCMDB probe do not synchronise credentials during SAP ABAP discovery job

I'd say to assign the SAP account to your SAP servers only and retest

Valued Contributor
Grzegorz_83
Posts: 40
Registered: ‎05-05-2010
Message 3 of 7 (825 Views)

Re: uCMDB and uCMDB probe do not synchronise credentials during SAP ABAP discovery job

Probably you entered wrong credentials definition - make sure, that sap servers' ip is in probes' range and credentials for sap are valid for that probe and range.

 

regards

Gregory

Advisor
WDBSort1
Posts: 12
Registered: ‎08-07-2012
Message 4 of 7 (810 Views)

Re: uCMDB and uCMDB probe do not synchronise credentials during SAP ABAP discovery job

Hi Gregory.

 

I have checked that the credentials are valid for the probe and the range. The interesting thing is that we can discover 4 of the SAP systems we need, but the other 4 generates the errors as before.

 

We also found that when we hardcode the information for the credentials in the Edit Discovery Pattern dialog box, the discovery job gets the information as required. By hardcode I mean entering the credentials manually as per the screenshot attached.

 

Any thoughts?

 

Regards,

 

Wynand.

Valued Contributor
Grzegorz_83
Posts: 40
Registered: ‎05-05-2010
Message 5 of 7 (793 Views)

Re: uCMDB and uCMDB probe do not synchronise credentials during SAP ABAP discovery job

I would still check if credentials definition doesn't have selected probe not only ip address.

 

Besides you should check CM (Confidential Manager) logs both on server and probe to see if there are any errors in synchronization. I would start with scurity.cm.client.log (or similar) on probe, to see if number of entries matches number of defined credentials.

 

regards

Gregory

Advisor
WDBSort1
Posts: 12
Registered: ‎08-07-2012
Message 6 of 7 (784 Views)

Re: uCMDB and uCMDB probe do not synchronise credentials during SAP ABAP discovery job

Hi Gregory.

 

I found this in the WrapperProbeGW.log :

 

<2013-04-12 08:42:57,444> 674251126 [INFO ] [ProbeGW Tasks Downloader] (ProbeTasksDistributerPull.java:672) - Confirm Tasks - Probe Gateway received 1 unsynchronized jobs from server
jvm 1 | <2013-04-12 08:42:57,445> 674251127 [INFO ] [ProbeGW Tasks Downloader] (ProbeTasksDistributerPull.java:766) - Probe is not synchronized with server - removing job MZ_MCA_SAP_SAP ABAP Connection by SAP JCO
jvm 1 | <2013-04-12 08:42:57,446> 674251128 [INFO ] [ProbeGW Tasks Downloader] (TaskDispatcher.java:129) - Probe Manager received task to remove job MZ_MCA_SAP_SAP ABAP Connection by SAP JCO
jvm 1 | <2013-04-12 08:42:57,454> 674251136 [INFO ] [ProbeGW Tasks Downloader] (ProbeTasksDistributerPull.java:349) - ProbeGW Tasks confirmer finished after 22 msec
jvm 1 | <2013-04-12 09:08:28,612> 675782294 [INFO ] [ProbeGW Tasks Downloader] (ProbeTasksDistributerPull.java:345) - ProbeGW Tasks confirmer started
jvm 1 | <2013-04-12 09:08:28,615> 675782297 [INFO ] [ProbeGW Tasks Downloader] (JobExecuter.java:1580) - getting All Job information took:1 msec
jvm 1 | <2013-04-12 09:08:28,615> 675782297 [INFO ] [ProbeGW Tasks Downloader] (ProbeTasksDistributerPull.java:667) - Confirm Tasks - Sending to Server: [MZ_SAP_SAP_SAP Applications by SAP JCO:3, MZ_MCA_Databases_DatabasesWizard_Databases TCP Ports:4, MZ_SAP_SAP_SAP ABAP Connection by SAP JCO:11, MZ_MCA_Infratructure_Network_Client Connection by SNMP:1, DS_SCOMMOM_Import Availability:1, MZ_FLAT_Collect Network Data by NetFlow:1, DS_SCCM 2012_SMS Population job:1, MZ_MCA_Software Config - Basic_ADM_Host Resources and Applications by WMI:4, MZ_MCA_Infratructure_Network_Range IPs by ICMP:1, MZ_FLAT_Network Connectivity Data Analyzer:1, MZ_SAP_SAP_SAP Java Topology by SAP JMX:6, DS_SCOMMOM 2012_Import Availability:1, MZ_SAP_SAP_SAP ABAP Topology by SAP JCO:3, MZ_FLAT_MS Domains Topology:2, MZ_FLAT_MS Domains:1, MZ_MCA_SAP_SAP ABAP Connection by SAP JCO:3, MZ_MCA_Infratructure_Network_Host Connection by WMI:4, DS_SCCM_SMS Population job:1, MZ_MCA_Inventory_InventoryDiscoveryWizard_Host Resources and Applications by WMI:4]

 

Does the above message confirm that the probe & server is not synchronising?

 

How do we fix this?

 

Regards,

 

Wynand.

Advisor
WDBSort1
Posts: 12
Registered: ‎08-07-2012
Message 7 of 7 (761 Views)

Re: uCMDB and uCMDB probe do not synchronise credentials during SAP ABAP discovery job

Good day.

 

Can anyone add anything to this problem?

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.