Re: Sitescope 9.5 NT Performance Counters (problem still in SS 11.22) (229 Views)
Reply
Occasional Contributor
kirk brady
Posts: 6
Registered: ‎06-09-2009
Message 1 of 5 (319 Views)

Sitescope 9.5 NT Performance Counters

Hi

We renamed a production server and the majority of the existing counters worked - the exception is the performance counters for specific MSMQ queues.

Selecting the MSMQ counter object name results in the message *** Counter object not found in the system*** after pressing the 'List Objects and Enumerate Counters' button.

Other performance counters such as WMI objects work fine.
The counters work within perfmon (Win2k3).
I have used LODCTR to reload mqperf.ini

Any thoughts as to how to progress?
Respected Contributor
Konstantin.Kornienko
Posts: 250
Registered: ‎12-25-2005
Message 2 of 5 (243 Views)

Re: Sitescope 9.5 NT Performance Counters (problem still in SS 11.22)

Have exactly same problem in SiteScope 11.22

 

The problem is that MSMQ full counter name in monitor will look like this

 

MSMQ Queue\server-name\private$\admin_queue$\Messages in Queue

 

 

Obviously it messes up Sitescope, because counter instance contains '\' chars itself.

 

Can't manage to fix it, tried something like

MSMQ Queue\server-name\\private$\\admin_queue$\Messages in Queue

didn't help

 

Funny - if you specify counter name with regex

/^MSMQ Queue\.*\Messages in Queue$/

SiteScope will find all counters correctly:

 

MSMQ Queue\server-name\private$\admin_queue$\Messages in Queue

MSMQ Queue\server-name\private$\server_queue$\Messages in Queue

...

 

But SiteScope can't get values for counters :(

 

Anybody know how to fix this?

Respected Contributor
Konstantin.Kornienko
Posts: 250
Registered: ‎12-25-2005
Message 3 of 5 (235 Views)

Re: Sitescope 9.5 NT Performance Counters (problem still in SS 11.22)

Have found workaround

 

change remote server connection to NETBIOS, everything start to work :(

HP Expert
kenneth.gonzalez
Posts: 1,643
Registered: ‎04-28-2011
Message 4 of 5 (233 Views)

Re: Sitescope 9.5 NT Performance Counters (problem still in SS 11.22)

Porblem may be with WMI.

"The counters work within perfmon (Win2k3)"

You may validate by running perfmon in wmi mode and by SiS service user:

Runas /user DOMAIN\user "perfmon.exe /wmi"
Kenneth Gonzalez
HP Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums
Respected Contributor
Konstantin.Kornienko
Posts: 250
Registered: ‎12-25-2005
Message 5 of 5 (229 Views)

Re: Sitescope 9.5 NT Performance Counters (problem still in SS 11.22)

Thanks for your suggestion, Kenneth.

 

I think perfmon.exe /wmi doesn't work in current OS'es - Win7/2008.

 

And the problem is that OTHER counters (for example, Processor or Memory) work well via WMI/NETBIOS. But MSMQ counters - only via NETBIOS.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.