Re: Sitescope 11.10 Installation Problem on RHEL 5.8 (781 Views)
Reply
Occasional Collector
vpraveenn
Posts: 2
Registered: ‎04-12-2012
Message 1 of 5 (822 Views)
Accepted Solution

Sitescope 11.10 Installation Problem on RHEL 5.8

Hello All,

 

I was trying to install Sitescope 11.10 over Redhat Linux Server,  while trying to execute the installer Binary, it interrupts with the below message " 

 

"Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
Please run the installer as root!

WARNING! This installation has been interrupted. The
installation process will now terminate and the temporary
files it is using will be deleted from /tmp/install.dir.28908. "

 

Does anyone have any idea on what is wrong with this installation, as when I was going through some support documentations, it is is not recommended to install this software with the "Root" user.  Any help would be greatly appreciated.

Esteemed Contributor
Sergey  Popov
Posts: 295
Registered: ‎03-10-2010
Message 2 of 5 (807 Views)

Re: Sitescope 11.10 Installation Problem on RHEL 5.8

Nothing is wrong and I suspect that documentation advises against running the software as root (it is generally a bad idea, yes).

 

However, SiteScope is shipped in .rpm packages and to use package manager you have to be root.

It can be avoided, if you really want - via private rpm database for user - but… just don't do it.

 

So, I suggest following the installer's advice and run it from the root account.

_______________
This thread is now 20% cooler
Advisor
Erez.Gabay
Posts: 22
Registered: ‎11-24-2008
Message 3 of 5 (793 Views)

Re: Sitescope 11.10 Installation Problem on RHEL 5.8

[ Edited ]

this is really bad .... how it can be that root is mandatory for installation/administration on the new BSM.

a big "no no".

Occasional Collector
vpraveenn
Posts: 2
Registered: ‎04-12-2012
Message 4 of 5 (784 Views)

Re: Sitescope 11.10 Installation Problem on RHEL 5.8

Thanks

 

Installation location and setting account permission

 

SiteScope does not need to be installed or run by the root user unless the

SiteScope Web server is run on a privileged port

 

 

 

Respected Contributor
dcsbeemer
Posts: 299
Registered: ‎07-19-2011
Message 5 of 5 (781 Views)

Re: Sitescope 11.10 Installation Problem on RHEL 5.8

It's probably possible to just run the installer with a normal user that has the appropriate sudo privileges, as is the case with most installers?

 

So instead of logging into the root account itself, just use a normal account with sudo, i.e. instead of typing in for instance ./install.sh it would be sudo ./install.sh.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.