Server appears to be behind Load Balancer (189 Views)
Reply
Valued Contributor
krajeeve
Posts: 40
Registered: ‎10-15-2012
Message 1 of 2 (189 Views)
Accepted Solution

Server appears to be behind Load Balancer

Hi Friends

 

In the RUM Engine - Probe Traffic discovery page (domain view)  - under more details its mentioned like  '*Server appears to be behind Load Balancer'  . 

 

Is this a problem? does this affect the RUM monitoring to that server? If so what is the best practice?

 

regards

Rajeeve
 

Please use plain text.
HP Expert
Dmitry Shevchenko
Posts: 4,731
Registered: ‎01-30-2008
Message 2 of 2 (177 Views)

Re: Server appears to be behind Load Balancer

It doesn't really matter whether web/app server is behind LB or not. Actually in vast majority of production environments web/app servers are always behind LB, so this is pretty much common situation. What matters is where you put your RUM probe in such deployment.

 

If you put your RUM Probe before LB, RUM probe won't be able to monitor individual servers, as in this case for RUM it will be only one "server" - LB itself. So the best practice is to put RUM Probe behind LB as well, so that RUM could recognize every individual web/app server. However, in this case there may be another problem - "client" for RUM would be LB, not real uers. In order to avoid this problem LB should be configured to support X-Forwarded-For header that will keep original client IP. RUM Probe knows how to work with XFF headers.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation