Re: OMi- Certificate not able to send thrugh Loadbalancer (2502 Views)
Reply
Regular Advisor
AshishGupta
Posts: 125
Registered: ‎12-06-2010
Message 1 of 8 (2,604 Views)

OMi- Certificate not able to send thrugh Loadbalancer

Hi ,

 

Am looking to integrate HP OMi 9.22 & OMW 9.00 ,  as per the guide

 

a)   i have copied the opr-cli.jar & BBCTrustServer.bat from the DPS server  to the OM Server in required directories  and 

       then executed BBCTrusServer.bat from DPS to the OMW server and certifcate added successfully

 

b) Then I tried BBCTrustServer.bat to the Loadbalancer , it is getting failed with ERROR: Operation failed. Reason: Connection reset  , i checked port 383  also , telnet  is  also going well to loadbalncer, but not sure why its failing.

 

LB is configured on OSL level 4 as per recommendation , any pointers what can be the possible error , Even i tried adding directly a gateway server , i can see its going well, but loadbalncer is not working fine , I can access the application withput any issues using Loadbalancer.

 

Regards,

Ashish

 

HP Expert
PatWest
Posts: 836
Registered: ‎03-06-2008
Message 2 of 8 (2,599 Views)

Re: OMi- Certificate not able to send thrugh Loadbalancer

hi,

 

Try running postinstall.bat from gateway HPBSM/bin directory and put loadbalancer address when requested. Postinstall will configure it,

 

Default Virtual Gateway Server for Application: http://{BSM GW FQDN}:80

Default Virtual Gateway Server for Data Collectors: http://{BSM GW FQDN}:80 

 

The Loadbalancer is using port 80 for the Application and port 80+383 for the Data Collectors.

 

Hope this helps,
PatW

Regular Advisor
AshishGupta
Posts: 125
Registered: ‎12-06-2010
Message 3 of 8 (2,597 Views)

Re: OMi- Certificate not able to send thrugh Loadbalancer

Hi Pat,

 

Thanks for your reply , This Setting :

Default Virtual Gateway Server for Application: http://{BSM GW FQDN}:80

Default Virtual Gateway Server for Data Collectors: http://{BSM GW FQDN}:80

 

I have already configured  these settings , and am able to access the LB URL without  any issues , my issue is :

 

when am trying to run the BBCtrust from OMW server:

 

AM getting below

 

E:\Program Files\HP\HP BTO Software\bin\win64>BBCTrustServer.bat ********** ( have hidden name)

ERROR: Operation failed. Reason: Connection reset

 

Will Postinstall. bat make any change to the above scenario ?

 

Regards,

Ashish

 

HP Expert
PatWest
Posts: 836
Registered: ‎03-06-2008
Message 4 of 8 (2,573 Views)

Re: OMi- Certificate not able to send thrugh Loadbalancer

Postinstall.bat should enable configure the LB - to get rid of the error. Let us know if it helps.
Regular Advisor
AshishGupta
Posts: 125
Registered: ‎12-06-2010
Message 5 of 8 (2,568 Views)

Re: OMi- Certificate not able to send thrugh Loadbalancer

Pat , I tried the postinstall.bat on both the gateway serves and configured the LB , but no luck , still the issue persists..
HP Expert
PatWest
Posts: 836
Registered: ‎03-06-2008
Message 6 of 8 (2,550 Views)

Re: OMi- Certificate not able to send thrugh Loadbalancer

Disable the Load Balancer and try again, if possible, to narrow down the error.

 

Do you have a HTTP proxy as well in your environment?

Regular Advisor
AshishGupta
Posts: 125
Registered: ‎12-06-2010
Message 7 of 8 (2,526 Views)

Re: OMi- Certificate not able to send thrugh Loadbalancer

-Disabling the loadbalancer is not possible

- http proxy is not there in environment  . I tried bbcutl on m LB and gateway server  and got differnet results , so am bit worried now , here are the results:

 

a) LB URL

E:\Program Files\HP\HP BTO Software\bin\win64>bbcutil -ping https://abc.com

 

https://abc.com:

          (bbc-288) status=eServiceError coreID= bbcV= appN= appV= conn=0

          time=630 ms

 

b) GAteway URL

:\Program Files\HP\HP BTO Software\bin\win64>bbcutil -ping https://xyz.com

 

https://xyz.com :

          (bbc-289) status=eSSLError time=720 ms

 

i think error should come same , please correct me .

 

I have double checked 383 port is enabled on LB , telnet goes fine , is there anyother thing i should check ...

 

Should i import and export the certificates directly between OMW and Gateway servers?

 

Regards,

Ashish

HP Expert
PatWest
Posts: 836
Registered: ‎03-06-2008
Message 8 of 8 (2,502 Views)

Re: OMi- Certificate not able to send thrugh Loadbalancer

hi, sorry for delayed reply, did you reimport & export the certificates directly on GW and OMW servers?
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.