HP BSM 9 and SiteScope 11 Integration - CI statuses not updating (5507 Views)
Reply
Valued Contributor
Jerry Heiselman
Posts: 64
Registered: ‎08-22-2006
Message 1 of 12 (5,507 Views)
Accepted Solution

HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

We are working on a POC system and we have install SiteScope 11.02 and BSM 9.01. We followed the instructions for doing the OA based event integration with BSM/OM and also did the usual integration by linking SiteScope to a profile in SAM.  The event based integration is working perfectly and the System Monitors view is showing the CIs created within the appropriate groups, however, non of the CI KPIs are getting updates. They are blue. They have never reported and nothing we tried (deleting the profile and recreating it, hard-sync, soft-sync) is working.

 

Anyone have any ideas on this one?

HP Expert
Asaf Shechter
Posts: 1,353
Registered: ‎12-09-2008
Message 2 of 12 (5,506 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

Please verify that the CIs were created OK (i.e you see the monitored CI in System Hardware monitors view) and that you see the Events in Event Browser.

If not, you need to solve these items first.

If yes, look at the Event details in the Event Browser and see why it wasn't resolve to CI or ETI. Usually, when it is not resolved to ETI is because users didnt deploy the default content packs (under HPBSM\bin\bsm_deploy_content_packs.bat or similar name).

Valued Contributor
Jerry Heiselman
Posts: 64
Registered: ‎08-22-2006
Message 3 of 12 (5,506 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

The CI's are being created properly down to the SiteScope Monitor CI and it is being properly associated with the Host CI. The events are coming is just fine and the CI in the event details is mapped appropriately to the correct Host CI. Should it instead be mapped to the monitor CI? And yes, I deployed the default content packs .

 

Did I perhaps need to re-run the default content pack installer after I installed patch 9.02 or would that patch have taken care of updating those for me? I didn't see anything in the installation instructions regarding that.

HP Expert
Asaf Shechter
Posts: 1,353
Registered: ‎12-09-2008
Message 4 of 12 (5,506 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

The events should NOT be mapped to the monitor!! There is no Impact relationship between the monitor and the Node. The events should arrive directly to the Node and affect HI on it which will then contribute to KPI.

Make sure that the HI definition on Node is correct (goto Admin > SH > Repositories > Indicators).

Can you add screenshot of the Event which you think should be mapped to HI on the Node? The important tab is the Resolver hints tab.

Valued Contributor
Jerry Heiselman
Posts: 64
Registered: ‎08-22-2006
Message 5 of 12 (5,506 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

The Health Indicators appear to be correct. In my example (screenshots attached) there is a ping monitor event forwarded from SiteScope to BSM/OM. The related CI is correct and in the IT Universe Manager, the node CI is mapped to the monitor properly. The SH view still shows blue (not up to date) for this monitor as you should be able to see from the attached Health Perspective screenshot. I've also attached the SH Indicator configuration for the Node CI type.

HP Expert
Asaf Shechter
Posts: 1,353
Registered: ‎12-09-2008
Message 6 of 12 (5,506 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

You didnt show the Event details and the resolver tab.

try to restart BSM to see if new Events will be forwarded from OMi to online_engine

Valued Contributor
Jerry Heiselman
Posts: 64
Registered: ‎08-22-2006
Message 7 of 12 (5,506 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

Here is the resolver tab from the event details. I can't quite restart BSM right now as others are using it, but if you still feel that this is the problem, then I will get it done as soon as I can.

HP Expert
Asaf Shechter
Posts: 1,353
Registered: ‎12-09-2008
Message 8 of 12 (5,506 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

so as you can see, the event wasnt resolved to the node (unsuccessful CI resolved) and the event was resolved to the SiS server. moreover, there is no ETI hint on the event (unknown:unknown). you  should publish the metric to indicators mapping from SAM admin to all SiS. anyway, i suggest contact HP Support if you need assistance in troubleshooting CI resolver in OMi.

Valued Contributor
Jerry Heiselman
Posts: 64
Registered: ‎08-22-2006
Message 9 of 12 (5,506 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

Okay, thanks for your help

Valued Contributor
Jerry Heiselman
Posts: 64
Registered: ‎08-22-2006
Message 10 of 12 (5,461 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

Okay, for those who encounter the same thing, the issue was that the BSM server and the database server were in different timezones (not physically, just by configuration). ALL of BSM's servers must be configured with the same timezone setting despite being able to set the timezone when creating the profile database connection in Admin->Platform. For some reason, it is standard practice here to set the Unix systems to UTC and the Windows systems to local time. We changed the Windows systems, reinstalled and everything works perfectly now.

Occasional Advisor
Prasse
Posts: 10
Registered: ‎01-21-2010
Message 11 of 12 (5,412 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

Jerry, Can you please attach a screenshot of how the event browser looks now?

Also if possible please attach a screenshot of the top view showing system monitors KPI  info.

 

We recently finished BSM 9.01 install and integrated Sitescope 10.10. HP says if we upgrade to SiS 11. then we will see the KPI's for System Monitors which I'm not sure.

 

Thanks

Prasse.

Occasional Advisor
ucmdbuser
Posts: 9
Registered: ‎05-05-2010
Message 12 of 12 (5,252 Views)

Re: HP BSM 9 and SiteScope 11 Integration - CI statuses not updating

Hello Jerry

Here you mentioned "OA based event integration" betweeen Sitescope and BSM. I am trying the same but not working.

I get the error "cannot get coreID of manager". can you write in short @ steps you followed to do the event integration.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.