Re: BSM is refusing to run a Webservice VUGen script. (482 Views)
Reply
Occasional Contributor
SharathC
Posts: 6
Registered: ‎01-27-2014
Message 1 of 6 (541 Views)
Accepted Solution

BSM is refusing to run a Webservice VUGen script.

BSM/BPM version: 9.22.131 Intermediate Patch

LoadRunner VUGen version: 11.51 build 3392

 

The VUGen script has been uploaded into BSM with proper threshold settings. The script execution is failing due to the below error which was captured from BPM run logs. Please help on how to resolve this...

 

Start auto log messages stack - Iteration 1. [MsgId: MMSG-10545]

28/01/2014 04:02:44 Starting action Action. [MsgId: MMSG-15919] 28/01/2014 04:02:44 Action.c(24): Notify: Transaction "[removed_txn_name]" started. [MsgId: MMSG-16999] 28/01/2014 04:02:44 Action.c(28): Error:InvokeMethod failure: Could not load file or assembly 'file:///D:\ProgramData\HP\BPM\workspace\agent1\task_invoker\_uid_6_\iesnprd\WSDL\IESNLoggingServiceConcreteWSDL\Net\IESNLoggingServiceConcreteWSDL_0_0_Proxy.dll' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.. [MsgId: MERR-108906] 28/01/2014 04:02:44 Action.c(28): Error:ExtractResultArg failure: Object reference not set to an instance of an object.. [MsgId: MERR-108903] 28/01/2014 04:02:44 Action.c(28): Error:Web service call "sendLogWithReply_101" execution failed [MsgId: MERR-108960] End auto log messages stack. [MsgId: MMSG-10544]

Please use plain text.
HP Expert
PatWest
Posts: 831
Registered: ‎03-06-2008
Message 2 of 6 (507 Views)

Re: BSM is refusing to run a Webservice VUGen script.

Please use plain text.
Valued Contributor
noamhasin
Posts: 78
Registered: ‎11-20-2011
Message 3 of 6 (482 Views)

Re: BSM is refusing to run a Webservice VUGen script.

[ Edited ]

open the file C:\HP\LoadGenerator\bin\mdrv.exe.config in a text editor,

And add the following lines to it after the <configSections> section:

 

  <startup useLegacyV2RuntimeActivationPolicy="true">

    <supportedRuntime version="v4.0"/>

  </startup>

 

The file mdrv.exe.config should be like this:

--------------------------------------------------------------------------------------------

<?xml version="1.0" encoding="utf-8"?>

<configuration>

  <configSections>

    <section name="microsoft.web.services2" type="Microsoft.Web.Services2.Configuration.WebServicesConfiguration, Microsoft.Web.Services2, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

    <section name="microsoft.web.services3" type="Microsoft.Web.Services3.Configuration.WebServicesConfiguration, Microsoft.Web.Services3, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

</configSections>

 

  <startup useLegacyV2RuntimeActivationPolicy="true">

    <supportedRuntime version="v4.0"/>

  </startup>

 

  <microsoft.web.services2>

    <security>

      <x509 storeLocation="CurrentUser" allowTestRoot="true" />

    </security>

  </microsoft.web.services2>

  <microsoft.web.services3>

    <security>

      <keyIdentifierMapping>

        <add valueType="http://docs.oasis-open.org/wss/oasis-wss-saml-token-profile-1.1#SAMLV1.1" tokenType="http://docs.oasis-open.org/wss/oasis-wss-saml-token-profile-1.1#SAMLV1.1" />

      </keyIdentifierMapping>

      <x509 allowTestRoot="true" />

      <securityTokenManager>

        <add type="CsSAMLHelper.LrSAMLTokenManager, CsSAMLHelper" namespace="urn:oasis:names:tc:SAML:1.0:assertion" localName="Assertion" />

      </securityTokenManager>

      <binarySecurityTokenManager>

        <add valueType="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-x509-token-profile-1.0#X509v3">

          <keyAlgorithm name="RSA15" />

        </add>

      </binarySecurityTokenManager>

    </security>

  </microsoft.web.services3>

 

</configuration>

Functional Architect
Please use plain text.
Occasional Contributor
SharathC
Posts: 6
Registered: ‎01-27-2014
Message 4 of 6 (473 Views)

Re: BSM is refusing to run a Webservice VUGen script.

This solved my problem. Adding to this. I modified "C:\HP\BPM\bin\mdrv.exe.config", instead of "C:\HP\LoadGenerator\bin\mdrv.exe.config".

 

Thank you very much !

Please use plain text.
Frequent Advisor
twinge
Posts: 53
Registered: ‎06-25-2012
Message 5 of 6 (452 Views)

Re: BSM is refusing to run a Webservice VUGen script.

Had the same issue. Solved. Thanks!

Please use plain text.
Occasional Visitor
kasaijaivan
Posts: 2
Registered: ‎05-15-2014
Message 6 of 6 (168 Views)

Re: BSM is refusing to run a Webservice VUGen script.

Had the SAME PROBLEM... You are GENIUS.. You Made My DAY

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation