Re: AJAX TruClient script will not FAIL! (744 Views)
Reply
Advisor
Joshua_Polier
Posts: 39
Registered: ‎02-23-2011
Message 1 of 2 (779 Views)

AJAX TruClient script will not FAIL!

Ok, let me setup this up:

 

BSM 9.22, BPM 9.22, VuGenSA 11.51

 

Key (or changed) VuGen Runtime Settings:

 

Standard Log (Log errors/warnings only)

Replay Options - (Checked) Failed end event causes step failure

Snapshots generation - Replay snapshots generation - On error

Action on error - Abort script

 

Script runs as it should in Developer and Load modes as well as fails when textCheck is changed to an invalid value in VuGen. No problem with VuGen.

 

I first created a simple "login and text check" script but for some reason it would not initialize on the BPM.  So then I scripted an more simple "browse to google", search, and verify search text with "verify" text check.  I uploaded this to BSM and everything seemed to be fine (green) except that I was not receiving any performance metrics to the reports even though the script seemed to be running fine.

 

I then changed the textCheck parameter I had created for text check to a value that should fail "ASDFLKAJDS".  Script still showed that it was running without error but then I did start receiving the performance metrics (including the times from when I was seeing nothing).  A few minutes later I started seeing transaction errors produced for the script runs but BSM still showed the script as "OK"... solid green since it started showing up.  The next issue was that the BPM Triage Raw Data Error log is showing that:

 

Error Name was "-1" with Error Message "N/A" and no snapshot.

 

or

 

Error Name was "0" with Error Message " - " and no snapshot.

 

I'm truly at a loss and could really use some help here.

 

Thank you,

 

Joshua

HP Expert
PatWest
Posts: 836
Registered: ‎03-06-2008
Message 2 of 2 (744 Views)

Re: AJAX TruClient script will not FAIL!

hi,

 

I'd start with some enhanced logging, perhaps this will give you more information of what's going on.

 

To Increase log level to agent.txt log, shut down BPM.


Change <inst dir>\config\agent1.cfg: set in [agent] section LogLevel to be LogLevel=debug

 

Now restart BPM.

 

After BPM has started, please go to script folder (under SiteX/?) and update the script's default.cfg file [Log] section:
[Log]
LogOptions=LogExtended
MsgClassData=1
MsgClassParameters=1
MsgClassFull=1
AutoLog=0

 

Wait till the issue happens again, and check the BPM logs if there is more details about the error.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.